Bennett Adelson Technical Blog

Bennett Adelson Technical Blog

SharePoint 2016 Preview Installation – Step 3 Configure Database Issue


I had trouble on SharePoint Configuration “Step 3 – Configure Database” when installing the SharePoint 2016 Preview on a single developer VM.

Step 3 never completed its processing after running for 8+ hours.

Here’s my work around:

  1. Disable UAC via the registry setting and reboot.
  2. Use the New-SPConfigurationDatabase powershell script to create the configdb.
  3. Run PSConfigUI to let the rest of the configuration operations (4 through 10) complete quickly.

The updated New-SPConfigurationDatabase command has a new mandatory parameter called -localserverrole. I specified “SingleServerFarm” for the server role. The command prompts for the other input parameters.

New-SPConfigurationDatabase finished successfully, but it did take hours to run.

Note: I’m happy with my development VM performance which is due in large part to SSD disk from which it runs.  I recommend this piece of hardware on your SharePoint 2016 development rig.

Leave a Reply or Comment

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: